View Full Version : Talisman roll back - possible workaround?

08-14-2016, 06:39 AM
I was also plagued with this bug. I removed the talisman from the carachter and then powered it up, went back to cosmos, returned to team and equipped. I went into battle, won and checked the level. It did not roll back.

Please, power up a talisman and see if this works for you as well.

- Remove talisman
- Power it up a few levels.
- Go to cosmos (not sure if this is necessary but do it anyway).
- Equip the talisman.
- Go to battle.
- Check the talisman again.

P.S. I suggest you don't go crazy with your gold and runes. Power it up a few levels and see. I don't want you to end up losing a ton of gold and then curse me here. :-D

Good luck and if this has already been offered as a solution, sorry for the repost.

Galaxy S7 Edge / Android

08-14-2016, 07:05 PM
Has anyone tried this yet?

08-15-2016, 04:22 PM
i tried it just now, it worked on one, but not on a 2nd when i repeated it with a different talisman.