So, I finally completed the 100 4* characters achievement and encountered a few bugs as that happened. First, as I got to 99 4* characters, the red number on the achievement icon on the main screen had increased by one, indicating that I had a new achievment to claim although I couldn't claim anything. As I got my 100 4* characters, the red number on achievement had increased by one again. As I claimed my rare GA soul, the same achievement popped up again and I could claim another rare GA soul.

Both souls turned up in the BoS (as two separate stacks) and I could summon both (got dupes... yay). After summoning the second of these souls, there was still a rare GA soul stack with 0 on its counter. I tried to summon a soul from this stack and the soul got "stuck" in the eddie mouth and the game "froze" (as in, I can't do anything but the vortex in the mouth and glitter on the souls is still moving and the soul stuck in the mouth is slowly spinning). The rare GA soul stack was still there, with x-1 on the counter.

Had to force quit the game. After restarting, I got both rare GA souls back and the two characters I pulled were gone (as it should be after force quitting from the BoS). Tried summoning again, and everything worked as it should (getting the same two dupes again of course).

And, while I'm not completely sure, I don't think those achievements was accounted for in my total completed achievement count.