Results 1 to 7 of 7
  1. #1

    "no buttons" so can't play - known issue, we're working on it

    World: 'Underworld', Level: 'Children of the Damned', Difficulty: 'Normal'

    Playing this level is not a problem, until the final "boss level" of enemies appear. For my account (and after several attempts to complete), the option to attack never loads when the final round of enemies load, and my team is stuck staring the enemy face to face... breathing and staring... into infinity.

    This would not be much of an issue if not for being the last "skulls" necessary to unlock the secret level in the Underworld on Normal difficulty.

    Transmitting this message to any/all who are capable of adressing such issues. Thank you for developing this wonderful game.

  2. #2
    Situation update:

    I have worked around the enemies.

    Until the next patch is released (read the forum posts), do not attempt to defeat the second wave while the blue (magus) children of the Damned are in the reflective bubbles. After the bubble is deflated/deactivated, destroying these enemies will allow the attack commands to load in the third (final) wave.

  3. #3
    I have the exact same problem , not worked around it yet like you have though !! Will try to but I'm not very patient !!!

  4. #4
    Junior Member
    Join Date
    Jul 2016
    This also happens on the Number of the beasy mission in the Underworld. Bad news is that when the last child casts his shield when low on life, you can't really do anythingto avoid the crash ... ans loss of trooper badges

  5. #5

    Interface not loading 1/2 way through Number of the beast

    When I get to the 3rd or 4th battle on Number of the beast, the interface does not load. The auto-play button was viable, but nothing happened when it was pressed. The game is not totally frozen. The characters idle animations still play. This happens on all 3 difficulties on numerous attempts. I am able to complete other 5-stage levels such as "A Matter of Life and Death". Screen Shot below.

    Name:  Number of the Beast interface not loading..png
Views: 194
Size:  1.33 MB

  6. #6
    Senior Member
    Join Date
    Jul 2016
    It's a known bug.

    It happened to me a lot, I was lucky enough to get all the crystals on the first try. I imagine trying to unlock the secret location would be terrible.

    Try to clear the cache, or deleting the app data. Don't uninstall the game. Just delete the data and next time you log in the game will download everything again.

    Hope it works.

  7. #7
    Junior Member
    Join Date
    Jul 2016
    This just happened in the heart of darkness normal mission.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts